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1 Scope 

1.1 Introduction 

Master – details entity relationships are very common in information-rich 
client server database systems. In accounting systems, this relationship is 
seen in the client – invoice relationship. 

In this tutorial, the master – detail relationship context is that of classes 
that are attended by students. Student may attend any number of classes. 

The basis of this tutorial can be found at 
http://fabrikar.com/help/tutorials/details/3/24 

1.2 Purpose 

The tutorial referenced in Section 1.1 was created in the context of Joomla 
version 3.2, and Fabrik version 3.1 RC2. 

This document seeks to present the substance of that video-based tutorial 
in a step by step fashion, breaking the overall exercise down into a 
number of activities, and their related tasks. 

We have also added an introductory chapter (i.e. Chapter 2) that seeks to 
present a design overview, comprising use cases, an entity-relationship 
diagram, and a number of screen mockups. 

These additional items can be helpful in gaining an overall perspective 
regarding what is being attempted in the tutorial. 

Unashamedly, this reference manual presents a 'blow by blow' approach 
in reproducing the original tutorial.  

While a video tutorial is very useful in gaining a quick overall view of a 
tool's capabilities, when it comes to actually digesting the material from a 
competency building perspective, trying to reproduce the behaviour 
illustrated in the video is a bit like trying to drink from a fire hydrant – 
possible – yes – but not very effective. 

1.3 Audience 

The audience for this document comprises the following stakeholders 
including: 

• Individuals who are trying to evaluate the capabilities of fabric; and 

• Individuals are seeking to acquire competency to design Fabrik-based 
components. 
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1.4 Tools environment 

The following tools were used to create the content contained in this 
reference manual: 

a. The use cases, and entity-relationship diagramme, presented in 
Chapter 2 were created using Visual Paradigm for UML (www.visual-
paradigm.com/ ) 

b. The screen mockups were created using MockupScreens 
(www.mockupscreens.com). 

c. The WAMP environment used for local hosting is Uniform Server, 
version 8.9.2 
(http://sourceforge.net/projects/miniserver/files/Uniform%20Server/8.9.2
-Coral/) 

d. The version of Joomla! used is 3.2. (See 
http://www.joomla.org/download.html ) 

e. The version of Fabrik use is http://fabrikar.com/download, look for 
version 3.1 RC2, (applicable to Joomla! 3.2) and click Download. 

1.5 Assumptions 

We have not described the steps needed to set up the WAMP (i.e. 
Uniform) server, or how to install Joomla! or Fabrik. 

Instructions to support these installations are freely available on the Web. 

1.6 About the SPI-LAB 

The SPI Laboratory (Pty) Ltd (www.spilab.co.za), amongst other themes, 
has a strong focus upon performing software quality assurance activities, 
with most attention being paid to the early phases of product development 
e.g. working with the client to develop the product specification, and the 
later parts of the lifecycle that focus on evaluating the quality of the 
delivered product. 

It is in the nature of our work that we spend a great deal of time on product 
evaluation activities. 

This body of work (i.e. the creation of the reference manual) was 
undertaken as part of a detailed CMS content building technology 
evaluation exercise. 
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2 A design perspective of the master – detail exercise 

2.1 Design overview 

2.1.1 Use cases 
 

 

 

2.1.2 Use case summary 

Name Documentation 

 User  

 Master - 
Detail Overview 

This tutorial presents an overview of the key steps 
to creating tables that have a master - detail 
relationship. 
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Name Documentation 

 Create 
Tables 

This exercise creates the master - details tables. 
In this exercise the master table is referred to as 
'classes', and the detail table is referred to as 
'students'. 

 Add 
Elements to 
Tables 

This exercise adds elements to the master and detail 
tables. Elements are synonymous with table columns. 

 Add Data to 
Tables 

The created tables now have some data (i.e. rows) 
added to them. 

 Join Master 
and Detail 
Tables 

Steps are now taken to join the tables so that the 
master - detail relationship is created. 

 Configure 
Master Detail 
display 

The presentation of the data in the master detail 
views is now configured. 

 Display 
Master-Detail 
view on 
Frontend 

The master - detail view is now configured to be 
visible on the frontend. 

2.2 Entity relationship Model 

2.2.1 Master Detail 
 

 

 

2.2.2 Summary 

Name Documentation 
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Name Documentation 

 Master Table This table holds the various class values 
(Geography, Maths etc) 

 Detail Table This table holds the values that define the students 
(e.g. Fred Smith. Anne Other). 

 

2.3 Screen mockups 

2.3.1 Backend: Classes View 
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2.3.2 Backend: Students View 
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2.3.3 Front end: Classes View 
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2.3.4 Front end: Students View 
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2.3.5 Frontend: Master View: Form 
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2.3.6 Front end: Detail View: Form  
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3 Create the Lists 
Access path: Fabrik → Lists → New 

3.1 1. Overview: 

This function provides the means for creating a new list, which will be called the Classes list. 

3.2 2. Activity: Build the Master and Detail list 

 The activity focuses upon creating the master and detail lists. 

The master list is called 'classes'. 

The detail list is called 'students'. 

3.3 3. Tasks: 

3.3.1 3.1 Create the master list 

 

Figure 1 Create a new list 
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3.3.2 3.2 Capture items under Details, and Publish 

 

Figure 2 Enter Details and Publish 

Under Details, enter the Label (i.e. Classes), under Introduction enter 'Classes contain 
students'. 

Under Publishing Tab, select 'Yes' for Published. Click 'Save'. 

3.3.3 3.3 Set the Access details 
Select the Access Tab. 

 

Figure 3 Set the Access details 

Change the default setting of Delete Records, from 'Registered' to 'Public'. 
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3.3.4 3.4 Set the Data details 
Select the Data Tab. 

 

Figure 4 Assign Data details 

In the Create New List field, enter 'demo_classes', as the list name. 

Then click 'Save and Close'! 

3.3.5 3.5 Create the detail list 
Access path: Fabrik → Lists → New 
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Figure 5 Create a new list 

3.3.6 3.6 Capture items under Details, and Publish 

 

Figure 6 Enter Details and Publish 

Under Details, enter the Label (i.e. Students), under Introduction enter 'Students belong in 
classes'. 

Under Publishing, select 'Yes' for Published. 
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3.3.7 3.7 Set the Access details 
Select the Access Tab. 

 

Figure 7 Set the Access details 

Change the default setting of Delete Records, from 'Registered' to 'Public'. 

3.3.8 3.8 Set the Data details, and Save 
Select the Data Tab. 
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Figure 8 Assign Data details 

In the Create New List field, enter 'demo_students', as the list name. 

Then click 'Save and Close'. The following display will then appear. 

 

Figure 9 The created lists 

3.4 4. Remarks: 

 This series of tasks completes the creation of the lists. 
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The next step is to add some elements to each list. 



JFA-URM-03 User Manual for Fabrik 
Master Detail example 
(Joomla 3.2 version) 

SPI LABORATORY (PTY) LTD

  

Page 18 Issue: 1 24 December 2013JFL-URM-03.Fabrik-Tutorial-Master-Detail-JM-32.doc 

4 Add Elements to Lists 
Access path: Fabrik → Elements → New 

4.1 1. Overview: 

This function provides the means for adding elements to lists. 

4.2 2. Activity: Add elements to the Master and Detail lists 

 The activity focuses upon creating elements that will be added to the master and detail lists. 

Elements will be added first to the 'classes' list. Elements will then be added to the 'students' 
list. 

4.3 3. Tasks: 

4.3.1 3.1 Select the Elements function 
Click on the Elements Tab. The following view will appear. 

 

Figure 10 The Elements view 
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4.3.2 3.2 Select the 'classes' view on the Form menu 

 

Figure 11 Select Forms -> Classes  

We want to filter to view to restrict the display to elements associated with the 'classes' list. 
This can be achieved by selecting either 'classes' from either the Forms or the Group 
dropdown menu's. The following view will be displayed. 

 

Figure 12 Elements filtered by Form selection 

Now select 'New', as shown in the figure below. 
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Figure 13 Create a new element 

4.3.3 3.3 'Classes' list: Create element 'label' 
Capture the following details for this element: 

a) Details: For Name enter 'label' 

b) Details: For label enter 'label' 

c) Details: Under Group, select 'Classes' 

d) Under Element type: Select 'field' 

e) Under Options: Advanced Tab: Maximum Length: Enter text '20'  

 

Figure 14 Capture the details for the 'label' element 
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4.3.4 3.4 List Setting 
Select the List View Setting sidebar Tab. 

a) Show in List: Select the 'Yes' option. 

 

Figure 15 List settings selections 

Then click 'Save and Close'! 

 

Figure 16 Elements view - 'label' added 
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4.3.5 3.5 Add elements for the 'students' list 
In the Form dropdown, select 'students'. The elements for the 'students' view will be 
displayed. 

 

 

Figure 17 Elements initially associated with 'students' 

4.3.6 3.6 Add elements to the 'students' list 
a) Add the 'name' element.  

b) List view settings: Show in List: Set the option to 'Yes. 

Click 'Save and Close'. 



SPI LABORATORY (PTY) LTD User Manual for Fabrik Master 
Detail example (Joomla 3.2 

version) 

JFA-URM-03

 

JFL-URM-03.Fabrik-Tutorial-Master-Detail-JM-32.docIssue: 1 24 December 2013 Page 23 

 

Figure 18 Add the 'name' element and Save. 

b) Details: Name: Enter 'class_id' element. 

c) Details: Label: Enter 'Class. 

d) Details: Element type, select 'database join'. 

e) Options: Data: List: Select 'demo_classes' 

f) Options: Data: Value: Select 'id' from the dropdown list. 

g) Options: Data: Label: Select 'label' from the dropdown list. 

Click 'Save and Close'. 
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Figure 19 Add element 'class_id' 

h) Select the 'List Settings' Tab (on the left). 

i) Show in list: Select the 'Yes' command button. 

 

Figure 20 Save element settings 

After the 'Save and Close' button has been clicked, the following view will be displayed. 
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Figure 21 Elements added to the 'students' list 

4.4 4. Remarks: 

This series of tasks completes the creation of the new elements associated with the 'classes' 
and 'students' lists. 

The next step is to add some data to each list. 
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5 Add Data to Lists 
Access path: Fabrik → Lists → View Data 

5.1 1. Overview: 

This function provides the means for adding data to lists. 

5.2 2. Activity: Add data to the Master and Detail lists 

 The activity focuses upon adding data to the master and detail lists. 

Data will be added first to the 'classes' list. Data will then be added to the 'students' list. 

5.3 3. Tasks: 

5.3.1 3.1 Select the Lists function 
Click on the Lists Tab. The following view will appear. 

 

Figure 22 The Lists view 

5.3.2 3.2 Click on View data for the 'classes' List 
After clicking on View data for the 'classes' list, the figure below will be viewed. 
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Figure 23 The list view – select 'Add' 

Click on 'Add'. 

5.3.3 3.3 'Classes' List: Add data content 
For the 'label' field, enter the value 'Geography'. 

Click 'Save'. 

 

Figure 24 Add data content to a row in the 'Classes' List 

5.3.4 3.4 'Students' List Add data content 
Select the Lists Tab. 
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Figure 25 List View 

For the 'students' row, click on 'View data'. 

 

Figure 26 'Students' List – Add a row 

Click 'Add'. 
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Figure 27 Add data values to fields 

In the Name field, type in 'Fred Smith', 

From the Class dropdown selection, select 'Geography'. 

Click 'Save. The following view will be displayed. 
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Figure 28 Row added to 'Students' List 

 

5.4 4. Remarks: 

This series of tasks completes the addition of individual rows of data to each list. 

The next step is to join the master list to the detail list, i.e. the 'classes' list to the 'students' list. 
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6 Join the Master and Detail Lists 
Access path: Fabrik → Lists → Select 'Classes' 

6.1 1. Overview: 

This function provides the means for joining two lists, in this instance a parent list (i.e. master 
list) to a child list (i.e. the detail list). 

6.2 2. Activity: Join the Master and Detail lists 

 The activity focuses upon joining the master and detail lists. 

6.3 3. Tasks: 

6.3.1 3.1 Select the Lists function 
Click on the Lists Tab. The following view will appear. 

 

Figure 29 Select the 'Classes' list 

6.3.2 3.2 Click on 'Classes' 
After clicking on the 'classes' link, the figure below will be presented. 
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Figure 30 Select the Data view 

Click on the 'Data' Tab. 

6.3.3 3.3 'Classes' List: Data View: Joins Tab: Add a join 
To create a list join (between the master list and the detail list), click on the 'Add' function, in 
the Joins group box. 

 

Figure 31 Click 'Add' in the Joins group box 

6.3.4 3.4 Define the Join parameters 
Set the values as follows: 



SPI LABORATORY (PTY) LTD User Manual for Fabrik Master 
Detail example (Joomla 3.2 

version) 

JFA-URM-03

 

JFL-URM-03.Fabrik-Tutorial-Master-Detail-JM-32.docIssue: 1 24 December 2013 Page 33 

a) Join type: 'left join' 

b) From: 'demo_classes 

c) To: 'demo_students' 

d) From column: 'id' (i.e. this is the primary key in the 'classes' list. 

e) To column: From the dropdown list, select the 'class_id' item. 

 

Figure 32 Capture the join details 

Click 'Save and Close'. 

6.3.5 3.5 New defined group 'classes – [demo_students]' 
Click on the Groups Tab. The following view will be displayed. A new group has been 
created (i.e. classes – [demo_students]). 
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Figure 33 Click on Groups 

Click on the Lists Tab, and click on 'View Data'. 

 

Figure 34 Select Lists Tab, click on View Data. 

The following view will be displayed. 
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Figure 35 Master and detail lists elements joined 

To view the Form, click on the Id of the Classes List, as in the figure below. 

 

Figure 36 To view the form that displays the joined fields 
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Figure 37 Form with joined lists 

6.3.6 3.6 To add 'Repeat Group' buttons to the form 
Click on the Groups Tab. The following view will be displayed. Select the group (i.e. classes 
– [demo_students]). 

 

Figure 38 To add 'Group buttons', click on 'Classes –[demo_students]' 

a) Repeat: Repeatable: Select the 'Yes' command button. 
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Figure 39 Configure the group button settings 

Click 'Save and Close'. The view in Figure 37 is now displayed as: 

 

Figure 40 The form with Group Buttons displayed 

 

6.3.7 3.7 Add a new student to the group 
Now select the Add button, and click it. 
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Figure 41 Add a new student 

A new row is added. Add 'Joe Doe' to the name field, and select 'Geography' for the class 
field. 

 

Figure 42 New student added - capture the details 

Click 'Save'. 

6.3.8 3.8 Unlink the detail list 'class' from the master list 
With reference to Figure 42, it is inconvenient to display the class for each student in a given 
group. The way to treat this is as follows.  
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Select Elements, and click on the 'class_id' element. 

 

Figure 43 Click on 'class_id' element 

 

Figure 44 Prepare to unlink the 'class_id' element from the parent 

Click on 'unlink'. Under Options, click 'Hidden' to set it to 'Yes'. 

Click 'Save and Close'. (You may be asked for a confirmation – click 'Save and Close; again). 
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Figure 45 Hide the element 

Redisplay Figure 42. It will now appear as follows. 

 

Figure 46 The class label is now hidden in the students view. 

Click on 'Add'. 
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Figure 47 Add new detail record 

A new row will be added. Add a new name to the row. 

 

Figure 48 New row added to detail list 

Click 'Save'. 
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Figure 49 The composite master - detail view 

6.4 4. Remarks: 

This series of tasks completes the addition of individual rows of data to each list. 

The next step is to join the master list to the detail list, i.e. the 'classes' list to the 'students' list. 
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7 Managing the Master and Detail lists display 

7.1 1. Overview: 

Various methods are described for managing the display of the joined master – detail lists. 

7.2 2. Activity: Configuring the Master and Detail features 

 The activity focuses upon the methods for managing the master and detail list displays. 

7.3 3. Tasks: 

7.3.1 3.1 Ordering rows in the master list view 
Access path: Fabrik → Lists → 'Classes' → Select 'View Data' 

 

Figure 50 The composite master - detail view 

There is a lot of duplicated  data in this list view. We will apply 'grouping' to the classes list. 
Grouping is often used in conjunction with joins – it splits the list into groups of lists, grouped 
by a given value. Here we will group by each class. 

Access path: Fabrik → Lists → Select 'Classes' → Select Data Tab. 



JFA-URM-03 User Manual for Fabrik 
Master Detail example 
(Joomla 3.2 version) 

SPI LABORATORY (PTY) LTD

  

Page 44 Issue: 1 24 December 2013JFL-URM-03.Fabrik-Tutorial-Master-Detail-JM-32.doc 

 

Figure 51 Modify the Group By configuration 

a) Group by: Group by: Select 'id' – pertaining to the classes id. 

b) Group by: Order by: Select 'demo_students.name.  

c) Group by: Template: Add '{demo_classes___label}' 

Click 'Save and Close'. 

Access path: Fabrik → Lists → Select 'Classes' → Select 'View data'. The rows will be re-
ordered, as in the following figure. 

Note that the label 'Geography' appears at the top of the list. 
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Figure 52 Master - detail view - re-ordered rows 

7.3.2 3.2 Removing redundant data from the master list view 
Access path: Fabrik → Elements → Groups - Select 'classes-[demo_students]' 

 

Figure 53 The elements – classes-[demo_students] view 

Select the columns to be hidden, as shown in the figure below. 
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Figure 54 Removing elements from the list view 

Click on the 'Remove from list view' Tab. The list view will be updated, as shown in the 
figure below. 

 

Figure 55 Elements removed from the list view 

Access path: Fabrik → Lists → Select 'Classes' → Select 'View data'. Note the removed 
elements. 
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Figure 56 Revised display – student elements removed 

 

Now we need to take steps to hide the elements associated with the 'classes' list. 

Access path: Fabrik → Elements → Groups - Select 'classes'.  

The following view will be displayed. 

 

Figure 57 Elements associated with the 'classes' list 
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Select the elements to be hidden.  

 

Figure 58 Select elements from the 'classes' list for hiding 

Then click on the 'Remove from list view' Tab. 

Access path: Fabrik → Lists → Select 'Classes' → Select 'View data'. Note the removed 
elements. 

 

Figure 59 'Classes' view with hidden columns 



SPI LABORATORY (PTY) LTD User Manual for Fabrik Master 
Detail example (Joomla 3.2 

version) 

JFA-URM-03

 

JFL-URM-03.Fabrik-Tutorial-Master-Detail-JM-32.docIssue: 1 24 December 2013 Page 49 

 

7.3.3 3.3 Hyperlink element to data from the master list view 
Access path: Fabrik → Elements → Groups - Select 'classes-[demo_students] ' 

 

Figure 60 The elements – classes-[demo_students] view 

Click on the 'name' element, as shown in the following figure. 

 

Figure 61 Click on the 'name' element 
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Figure 62 Click on 'unlink' 

Click on 'unlink', and then click on the List Settings Tab. In Link to details click the 'yes' 
radio button. 

 

Figure 63 Link to details 

Click 'Save and Close'. 

Access path: Fabrik → Lists → Select 'Classes' → Select 'View data' 
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Figure 64 Select a name 

Select a name from the list, and click on it. 

 

Figure 65 The form view is displayed 

If the 'Add' icon is clicked, a new row will be added to the 'students' list, but not to the 
'classes' list, as shown in the following figure. 
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Figure 66 Add a row 

Add details to the 'name' element, and click 'Save'. 

 

Figure 67 New row and details added to 'students' list 

Now add a new row to the 'classes' list and a new row to the 'students' list. 

Access path: Fabrik → Lists → Select 'View Data' 
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Figure 68 Add new row to 'classes' list 

Click on 'Add'. A new row will be added to the 'classes' list, and a new row will also be added 
to the 'students' list. 

 

Figure 69 New row and details added 
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Figure 70 Refreshed master – detail display 

 

7.3.4 3.4 Changing the template for the master list view 
With reference to Figure 70, the columns do not line up. We need to select a more appropriate 
template. 

Access path: Fabrik → Lists → List name 'classes '. (See the figure below). 

 

Figure 71 Select the 'classes' list 

Click on List name: 'classes'.  

Scroll down the page and find the 'Layout' group box.  
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Figure 72 Update the Layout configuration settings 

In the Layout Tab, change the following settings: 

a) Template: Change from 'default' to 'bootstrap' 

b) Admin template:  Change from 'default' to 'bootstrap' 

Click the 'Save and Close' Tab. 

Click on Fabrik → Lists → Classes → Select 'View Data'.  

 

Figure 73 Master - detail view using 'bootstrap' template 
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7.4 4. Remarks: 

This series of tasks completes the demonstration of some of the configuration possibilities. 

The next step is to display the master – detail lists in the front end. 
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8 Display the Master and Detail lists on the frontend 

8.1 1. Overview: 

After having explored the means for setting up the master – detail list relationships, we can 
display the results on the front end. 

8.2 2. Activity: Configuring the frontend display 

 The activity focuses upon the tasks for displaying the master – detail lists on the frontend. 

8.3 3. Tasks: 

8.3.1 3.1 Display the classes list 
Access path: Joomla → Menu Item Manager → Select 'New' 

 

Figure 74 Create a new menu link 

Under Details: Select Item Type. Click Select.  

Under Fabrik, click on 'List'. 
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Figure 75 Select Fabrik -> List 

 

Figure 76 Configure the details 

a) Details: Menu Title: Enter 'Classes List' 

b) Details: Menu item type: 'Classes' 

c) Details: Fabrik list: Select 'Classes' 

Click the 'Save and Close' Tab. The view is refreshed, as in the figure below. 
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Figure 77 Menu item added 

Click the 'Preview' Tab. (Top right corner) 

 

Figure 78 Front end view 

Click on the 'Classes List' menu item. 

The Master – detail view is presented, as shown in the figure below. 
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Figure 79 The master - detail view 

Click on a student name. The detail view will be presented, as in the figure below. 

 

Figure 80 The detail view 

8.3.2 3.2 Display the students list 
Access path: Joomla → Menu Item Manager → Select 'New' 
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Figure 81 Create a new menu link for the students list 

Under Select Item Type, the initial view will list only the top level items. Click on 'Fabrik' 
and the second tier items will be listed. Click on 'List'. 

 

Figure 82 Select Fabrik -> List 
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Figure 83 Configure the student list details 

a) Menu item details: Title: Enter 'Student list' 

b) Parameters (Basic): List: Select 'students' 

Click the 'Save' Tab. The view is refreshed, as in the figure below. 

 

Figure 84 Student list menu item added 

Click the 'Preview' Tab. (Top right corner) 
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Figure 85 Front end view 

Click on the 'Student List'.  The student list view is presented, as shown in the figure below. 

 

Figure 86 The student list view 

Click on 'Add' . The detail view will be presented, as in the figure below. 
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Figure 87 The student list detail view 

 

8.3.3 3.3 Display the classes form 
Access path: Joomla → Menu Item Manager → Select 'New' 

 

Figure 88 Create a new menu link 

Under Select Item Type, the initial view will list only the top level items. Click on 'Fabrik' 
and the second tier items will be listed. Click on 'List'. 
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Figure 89 Select Fabrik -> Form 

a) Details: Menu Title: Enter 'Classes Form' 

b) Required settings: Form: Select 'Classes' 

 

Figure 90 Configure the classes form menu item 

Click the 'Save' Tab. The view is refreshed, as in the figure below. 
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Figure 91 Classes form - menu item added 

Click the 'Preview' Tab. (Top right corner) 

 

Figure 92 Front end view 

The Master – detail view is presented, as shown in the figure below. 
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Figure 93 The classes form view 

8.3.4 3.4 Display the students form 
Access path: Joomla → Menu Item Manager → Select 'New' 

 

Figure 94 Create a new menu link 

Under Select Item Type, the initial view will list only the top level items. Click on 'Fabrik' 
and the second tier items will be listed. Click on 'List'. 
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Figure 95 Select Fabrik -> Form 

a) Details: Menu Title: Enter 'Students List' 

b) Required Settings: List: Select 'students' 

 

Figure 96 Configure the students form menu item 

Click the 'Save' Tab. The view is refreshed, as in the figure below. 



SPI LABORATORY (PTY) LTD User Manual for Fabrik Master 
Detail example (Joomla 3.2 

version) 

JFA-URM-03

 

JFL-URM-03.Fabrik-Tutorial-Master-Detail-JM-32.docIssue: 1 24 December 2013 Page 69 

 

Figure 97 Students form - menu item added 

Click the 'Preview' Tab. (Top right corner) 

 

Figure 98 Front end view 

The detail form view is presented, as shown in the figure below. 
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Figure 99 The students form view 

8.4 4. Remarks: 

This completes this tutorial exercise. 

 




